1

Topic: dts-hd to dts problem

Hybrid keeps dts-hd stream even if I select option "automatic dts-hd to dts".
I try making some debug output for you today.

2

Re: dts-hd to dts problem

Do that.
Will try to look at it later assuming there is a DebugOutput then.

Cu Selur

3 (edited by mparade 2017-06-07 17:41:07)

Re: dts-hd to dts problem

Selur wrote:

Do that.
Will try to look at it later assuming there is a DebugOutput then.

Cu Selur

Here you are.

4

Re: dts-hd to dts problem

I see the problem.
Muxing jobs get merged together which causes the extraction of the code to get lost. wink
-> looking into it

Cu Selur

Ps.: Disabling "Config->Internals->Handling->Minimize jobs" should work as a workaround until I fix the issue.

5

Re: dts-hd to dts problem

Selur wrote:

I see the problem.
Muxing jobs get merged together which causes the extraction of the code to get lost. wink
-> looking into it

Cu Selur

Ps.: Disabling "Config->Internals->Handling->Minimize jobs" should work as a workaround until I fix the issue.

Hybrid still keeps dts-hd stream even if I select option "automatic dts-hd to dts".
Debug output is here because it is too big to upload:

http://www.mammutmail.com/hu/download/c … a8c89c9d69

6

Re: dts-hd to dts problem

For the record: A debug output of the job creation would be enough and would save me lots of time reading the debug output.
-> will look into it

7 (edited by mparade 2017-06-20 21:00:16)

Re: dts-hd to dts problem

Selur wrote:

For the record: A debug output of the job creation would be enough and would save me lots of time reading the debug output.
-> will look into it

the DTS-HD stream is still not correctly handled (Hybrid kept the DTS-HD stream with automatic DTS-HD to DTS switched on....)

Sorry for that again, but I made the output for the complete process unfortunately, do you want me to make only for the job creation?

8

Re: dts-hd to dts problem

Will look at it in a few days busy atm.

9

Re: dts-hd to dts problem

Selur wrote:

Will look at it in a few days busy atm.

The latest DebugOutput on the thema is attached.

10

Re: dts-hd to dts problem

Argh looks like I broke something since the audio queue doesn't contain any more that the output should be dts and not dts-hd.
-> looking into it

11

Re: dts-hd to dts problem

Please try again, looked at the debug output:

F:\BD-50\2D\ATMENT\A GYURUK URA A GYURU SZOVETSEGE\LORD OF THE RINGS FELLOWSHIP\BDMV\PLAYLIST\00100.mpls;4352;dts;6;passthrough;1536;;;48000;;eng;0;10704.068;dts;0;1;don't change;;false;;false;7;false;;;;true;false;;;false;48000;unknown;dts;;false;true;false;3/2/1.1 / 3/2/1.1 / 3/2/0.1;1/1;;;;;None;;;;;;16;;;dts-hd;false;2;;;;;;;;;;;4352;6;false;F:\BD-50\2D\ATMENT\A GYURUK URA A GYURU SZOVETSEGE\LORD OF THE RINGS FELLOWSHIP\BDMV\PLAYLIST\00100.mpls;true;false;;

and according to it dts-hd extraction isn't enabled, otherwise, it should be:

F:\BD-50\2D\ATMENT\A GYURUK URA A GYURU SZOVETSEGE\LORD OF THE RINGS FELLOWSHIP\BDMV\PLAYLIST\00100.mpls;4352;dts;6;passthrough;1536;downsampleDTSHD;;48000;;eng;0;10704.068;dts;0;1;don't change;;false;;false;7;false;;;;true;false;;;false;48000;unknown;dts;;false;true;false;3/2/1.1 / 3/2/1.1 / 3/2/0.1;1/1;;;;;None;;;;;;16;;;dts-hd;false;2;;;;;;;;;;;4352;6;false;F:\BD-50\2D\ATMENT\A GYURUK URA A GYURU SZOVETSEGE\LORD OF THE RINGS FELLOWSHIP\BDMV\PLAYLIST\00100.mpls;true;false;

-> argh seems to be related to the container! smile

Cu Selur