1 (edited by speedyrazor 2015-12-19 17:27:54)

Topic: Prores interlaced flag

Hi, I am encoding from Prores to Prores and trying to use these ffmpeg interlace flags:

-flags +ildct+ilme -top 1

But the output prores file is still flagged as Progressive when viewed in JES Extensifier and Media Info (Scan Type).
I can see the material is interlaced, it contains interlaced frames, but the header flag is still progressive, is there another flag to set somewhere? Here is a bare ffmpeg command:

ffmpeg.exe -i testfile.mov -vcodec prores -profile:v 3 -vtag apch -flags +ildct+ilme -top 1 -f mov outfile.mov

Kind regards.

2

Re: Prores interlaced flag

a. moved to the 'AV Talk' since it doesn't seem to be Hybrid related. smile
b. don't think there is a way using ffmpeg to signal anything else than:

Scan type                                : Progressive
Original scan type                       : Interlaced
Original scan order                      : Top Field First

-> if you find a way to signal this more properly let me know, I'm also interested in it (stopped investigating it since the only one who ever asked me about it didn't have a problem with it, since Quicktime takes such content as interlaced).

Cu Selur

3

Re: Prores interlaced flag

Thanks for your reply. I found this link earlier, the bottom patch '0002-prores_kostya-implement-interlaced-encoding.patch':

https://ffmpeg.org/pipermail/ffmpeg-dev … 29474.html

Is this anything to get excited about?

4

Re: Prores interlaced flag

Nope, that is about interlaced encoding which works, from the looks of it the only problem is some flag inside the container that isn't as it should be. (since the mail is from 2012, I assuming using ' -vcodec prores_ks' would otherwise solve the problem)

Cu Selur