1 (edited by Selur 2016-10-30 15:43:27)

Topic: Yes, I'm working on Vapoursynth support,..

Just for those curious, here's a list of the Vapoursynth based filters I have written code for so far:

From time to time I add new filters to this list.
Once I got all the filters I think are needed for basic processing I will release some kind of 'experimental' extension for Hybrid.
This will be for Windows a package you need to extract into your Hybrid folder.
For Linux and Mac it will probably will be some instructions how to compile and integrate the stuff needed for Hybrid to use Vapoursynth.

Note: At least at the moment, I only plan to add 64bit Vapoursynth support, since I don't see any gain from adding 32bit Vapoursynth support.

Main reasons for adding Vapoursynth support:

  • Hopefully more stability by npt running into so many memory restrictions (64bit instead of 32bit).

  • Hopefully manageable cross-platform filtering.

  • Better 10bit precision handling than with Avisynth 32bit.

Cu Selur

Ps.: Don't hold your breath, it will still take quite some time before I got all the basic filters together, since I'm not really in a hurry and fixing existing bugs has priority.

2

Re: Yes, I'm working on Vapoursynth support,..

Kindly add

mvsfunc = https://github.com/HomeOfVapourSynthEvolution/mvsfunc
BM3D = https://github.com/HomeOfVapourSynthEvo … Synth-BM3D
Waifu-Caffe/w2xc = https://github.com/HomeOfVapourSynthEvo … fu2x-caffe / https://github.com/HomeOfVapourSynthEvo … ifu2x-w2xc

Very Very useful plugins and Functions..

3

Re: Yes, I'm working on Vapoursynth support,..

@RazorBurn: which functions from mvsfunc ? (it's part or the VapoursynthPlugins, since orther scripts use it, but the question is which functions need to be available for direct use?)

BM3D: argh, probably that will not happen in full any time soon, adding support for the basic parameters from mvsfunc -> BM3D will probably happen.

Waifu2x-caffe: "Requires cudnn64_5.dll (cuDNN v5.1 RC) to be in the search path. Due to the license of cuDNN, I can't distribute the required dll file. You have to register and download yourself at https://developer.nvidia.com/cudnn." -> can't distribute it myself so I will keep it in mind, but it probably won't be supported at the beginning.

w2xc  -> will look into it not sure if there are any dependencies.

4 (edited by Selur 2016-09-10 08:56:38)

Re: Yes, I'm working on Vapoursynth support,..

For those wanting to look like how the Vapoursynth integration looks like atm. I uploaded a small test-addOn. I'll delete the test-addOn in a few days. (-> deleted)

Cu Selur

5

Re: Yes, I'm working on Vapoursynth support,..

Mac OS X support probably won't come any time soon since I spend the whole Saturday trying to find a good and easy way for folks to install Vapoursynth and it's filters.

Only think that seemed like a usable solution was https://forum.doom9.org/showthread.php?t=173453 but from the looks of it, that was only a one-time-thing and will not get any updates.
Another way would be to write a tutorial how users could:
a. install vapoursynth through homebrew
b. manually compile and install all the required filters
but since I don't think it's a decent thing to have users install homebrew (and xcode) and require them to build and install the filters manually, Mac OS X probably won't get Vapoursynth support any time soon.

Looking into Linux support, if that also gives me problems I'll probably drop the whole Vapoursynth support.

Cu Selur

6

Re: Yes, I'm working on Vapoursynth support,..

Please don't drop Vapoursynth support. Any issues on Linux should be solvable, and the clean codebase of Vapoursynth is definitely the future. Maybe the djcj (the Ubuntu ppa maintainer could help with any issues, I would do so as well (but probably won't be of use hmm ).

My news stream on the phone showed that you have a test version now, I can't find it here. Where can I download it?

7

Re: Yes, I'm working on Vapoursynth support,..

Posted a link to a test version for Windows 64bit, see: Vapoursynth testing,... (no Linux test version available atm.)