1

Topic: NVENC unable to pick quantizer

I've searched through the entire forum before I am asking this question.  I am wondering why when I pick 1-pass constant quantiizer, there is no option that I can see to pick my number.  I did read that you said this was a bug, but that was in an earlier version of the program.  Is this bug still in the current version?  Using 2017.04.10-1  I do apologize if this has been answered and I just can't find it.  I know in older version it was there, or is it just not there because I am using the ffnvenc experimental and not actually nvenc.  If that is the case, how does one use regular nvenc?  Or if my question is just nonsense, please say so:)

I am using a pascal card, with drives 373.06 because I fold.

Thank you for your time and patience.

2

Re: NVENC unable to pick quantizer

It's there,...
Depending on whether Quantizer 'split' is active or not you can select three (for each frame type one) or one quantizer.

Cu Selur

Post's attachments

Attachment icon quantSelection.png 50.89 kb, 17 downloads since 2017-04-17 

3

Re: NVENC unable to pick quantizer

I don't have the regular nvenc tab like you do in your picture.  The only option I have for nvenc is nvenc(ffmpeg)
I thought I had uploaded a picture with it, but obviously it didn't make it.

http://i.imgur.com/vXq9Sft.png this is all I get when I go to the nvenc tab. As you can see it is not the same tab that you have.


Just wondering if I am doing something wrong somewhere.

Post's attachments

Attachment icon 2017-04-17.png 48.98 kb, 14 downloads since 2017-04-17 

4

Re: NVENC unable to pick quantizer

Try clearing your tool cache (Config->Tools->Clear ..)

Cu Selur

5

Re: NVENC unable to pick quantizer

It still only gives me nvenc(ffmeg)  This is a fresh install of windows 10 with the creator's update crap.

I'm using a 1080FTW is that makes an difference.

6

Re: NVENC unable to pick quantizer

Hybrid doesn't complain about the card not being  NVIDIA PureVideo compatible or does it?

7

Re: NVENC unable to pick quantizer

Not that I can see, no.  The program makes no complaints at all.

Though when I check features it gives me this
C:\Program Files\Hybrid>nvencc --check-device
DeviceId #0: GeForce GTX 1080

C:\Program Files\Hybrid>nvencc --check-features
Failed to create instance of nvEncodeAPI, please consider updating your GPU driver.
Environment Info
OS : Windows 10 (x64)
CPU: Intel Xeon(R) E5-2670 0 @ 2.60GHz [TB: 2.91GHz] (8C/16T)
RAM: Used 10826 MB, Total 16319 MB
GPU: Unknown (error on OpenCL clGetDeviceInfo)

No NVEnc support.

Attempting to update drivers now..though it will cost me folding points haha.

Will report back.

8

Re: NVENC unable to pick quantizer

"No NVEnc support." -> That is the reason Hybrid throws out NVEnc. smile

9

Re: NVENC unable to pick quantizer

Ok, so what do I do? haha.  After I've updated the drivers this is what I get now.

:\Program Files\Hybrid>nvencc --check-features
Environment Info
OS : Windows 10 (x64)
CPU: Intel Xeon(R) E5-2670 0 @ 2.60GHz [TB: 2.91GHz] (8C/16T)
RAM: Used 10813 MB, Total 16319 MB
GPU: Unknown (error on OpenCL clGetDeviceInfo)

List of available features.
Codec: H.264/AVC
Max Bframes               4
RC Modes                  63
Field Encoding            1
MonoChrome                0
FMO                       0
Quater-Pel MV             1
B Direct Mode             1
CABAC                     1
Adaptive Transform        1
Max Temporal Layers       0
Hierarchial P Frames      0
Hierarchial B Frames      0
Max Level                 51
Min Level                 1
4:4:4                     1
Max Width                 4096
Max Height                4096
Dynamic Resolution Change 1
Dynamic Bitrate Change    1
Forced constant QP        1
Dynamic RC Mode Change    0
Subframe Readback         1
Constrained Encoding      1
Intra Refresh             1
Custom VBV Bufsize        1
Dynamic Slice Mode        1
Ref Pic Invalidiation     1
PreProcess                0
Async Encoding            1
Max MBs                   65536
MAX MB per sec            983040
Lossless                  1
SAO                       0
Me Only Mode              1
Lookahead                 1
AQ (temporal)             1
10bit depth               0

Codec: H.265/HEVC
Max Bframes               0
RC Modes                  63
Field Encoding            0
MonoChrome                0
Quater-Pel MV             1
B Direct Mode             0
Max Temporal Layers       0
Hierarchial P Frames      0
Hierarchial B Frames      0
Max Level                 62
Min Level                 1
4:4:4                     0
Max Width                 8192
Max Height                8192
Dynamic Resolution Change 1
Dynamic Bitrate Change    1
Forced constant QP        1
Dynamic RC Mode Change    0
Subframe Readback         1
Constrained Encoding      0
Intra Refresh             1
Custom VBV Bufsize        1
Dynamic Slice Mode        1
Ref Pic Invalidiation     1
PreProcess                0
Async Encoding            1
Max MBs                   262144
MAX MB per sec            983040
Lossless                  1
SAO                       1
Me Only Mode              1
Lookahead                 1
AQ (temporal)             0
10bit depth               1

And it still does not give me the option to pick nvenc.

10

Re: NVENC unable to pick quantizer

Now:
a. reset defaults (Config->Defaults->Reset (all)->Reset selected)
b. clear tool cache (Config->Tools->Clear all ...)

Cu Selur

11

Re: NVENC unable to pick quantizer

Send you a link to my current dev version which should fix the 'constant quantizer'-selection bug for 'ffmpeg (NVEnc)'.

12

Re: NVENC unable to pick quantizer

Thank you so much.

13

Re: NVENC unable to pick quantizer

Is NVEnc shown now?

14

Re: NVENC unable to pick quantizer

Yes, everything is 100% now.  Thank you very much.

On payday I will buy you some coffees! smile