101

Re: Ubuntu repository - maintained by djcj

Will release a new version in a bit which assumes that all 1.7+ x265 builds are combi builds, so build be nice if you could update the x265 package when you add the new release to it.

Cu Selur

102

Re: Ubuntu repository - maintained by djcj

due to some compilations with the windows release, I'll release the new version this evening (~ in 12 hrs)

103

Re: Ubuntu repository - maintained by djcj

New x265 binaries supporting both bitdepths are available.

104 (edited by Timhuey 2015-07-05 03:54:30)

Re: Ubuntu repository - maintained by djcj

I installed Hybrid-tools and I got MP4BOX 0.5.1 DEV rev 4065 so I get an error that my MP4BOX is to old to support HEVC. Is there a way to get a later version of MP4BOX? Thanks for all your hard work. It makes it easier for us newbies. I think the Hybrid-tools package was 1:0.9.1~trusty

105 (edited by djcj 2015-07-05 05:02:30)

Re: Ubuntu repository - maintained by djcj

Timhuey wrote:

I installed Hybrid-tools and I got MP4BOX 0.5.1 DEV rev 4065 so I get an error that my MP4BOX is to old to support HEVC. Is there a way to get a later version of MP4BOX? Thanks for all your hard work. It makes it easier for us newbies. I think the Hybrid-tools package was 1:0.9.1~trusty

I think this is related to this issue: http://forum.selur.de/topic849-mp4box-v … ntent.html
0.5.1 is not the version from the official Ubuntu 14.04 repositories, that's 0.5.0+svn4288. Doesn't it work with that version? I would add gpac to the PPA if I knew that a specific version would work reliably.

edit:

Just read this post from Selur: http://forum.selur.de/post9033.html#p9033
So apparently a newer version of mp4box is required to support HEVC. Latest release is 0.5.2, I can add this to the PPA.

106

Re: Ubuntu repository - maintained by djcj

djcj wrote:
Timhuey wrote:

I installed Hybrid-tools and I got MP4BOX 0.5.1 DEV rev 4065 so I get an error that my MP4BOX is to old to support HEVC. Is there a way to get a later version of MP4BOX? Thanks for all your hard work. It makes it easier for us newbies. I think the Hybrid-tools package was 1:0.9.1~trusty

Just read this post from Selur: http://forum.selur.de/post9033.html#p9033
So apparently a newer version of mp4box is required to support HEVC. Latest release is 0.5.2, I can add this to the PPA.

Awesome thanks so much for that. I will let you know how it turns out.

107

Re: Ubuntu repository - maintained by djcj

New gpac is now available.

108

Re: Ubuntu repository - maintained by djcj

djcj wrote:

New gpac is now available.

Great! this will increase the functionality of Hybrid. Can't wait to try it.

109

Re: Ubuntu repository - maintained by djcj

It's working. I'm converting a clip from frozen bluray dvd to x265. I'm getting about 4 fps. Ouch! Lol .

Thanks  so much for making this work.  It's great.

110

Re: Ubuntu repository - maintained by djcj

I'm getting about 4 fps. Ouch! Lo

Using a faster preset will probably help. wink

111

Re: Ubuntu repository - maintained by djcj

@djcj: small heads up. Next Hybrid version will use avisynthExtension_150707.

112

Re: Ubuntu repository - maintained by djcj

I don't process any .avi  files.  Is there any reason for me to use avisynth with hybrid?  Just curious if I'm missing any functionality.

113

Re: Ubuntu repository - maintained by djcj

main reason for using avisynth would be better filtering options (in all categories), if you don't filter your content, no reason to use avisynth.

114

Re: Ubuntu repository - maintained by djcj

According to selur.de/sites/default/files/hybrid_downloads/version.txt and the downloads page the current release number is 2015.08.26.0 with 0 as the revision. However in the updates section of the forums and in the programs title bar it's revision 1. That leads to some problems with the automated updates so I have to edit the download script. Can I assume that the revisions 0 and 1 will always be the same and whenever a second update will be released on the same day it'll always be tagged as revision 2?

115

Re: Ubuntu repository - maintained by djcj

Yes, not sure what went wrong that the revision was labled 0, but normally there should be 1 then two, so assuming 0 and 1 are identical is okay. Sorry, for the mishap, had a flue with fever (still not totally well) and was happy to have the version released and didn't pay much attention to the numbering. wink

Cu Selur

116

Re: Ubuntu repository - maintained by djcj

I've updated the package. Now it doesn't matter if the release was tagged as revision 0 or 1.

@Selur: Get well soon!

117

Re: Ubuntu repository - maintained by djcj

Small update:

  • the download window now shows a progress in percent

  • I fixed and updated the AviSynth extension installation

  • packages for Ubuntu 15.10 are now available

118

Re: Ubuntu repository - maintained by djcj

@djcj:

Just got the new version of Ubuntu 14.04 Hybrid installed.  Glad you were able to fix the AviSynth installation, but I am still having issues with AviSynth.  It hasn't worked for me since I upgraded to the August release.  WINE is up-to-date and loads nicely, but AviSynth stubbornly refuses to appear anywhere in Hybrid.  Even the options for forcing it on all the time or disabling it are not displayed.  Any thoughts on this predicament?

Thanks for your help!

119

Re: Ubuntu repository - maintained by djcj

Thanks for reporting that issue. I didn't see that the AviSynth tab was missing when I checked it. The problem was that with the new AviSynth extension files both avisynth.dll and DevIL.dll needed to be in the wine prefix. I just released an update which fixed that.

120

Re: Ubuntu repository - maintained by djcj

Hybrid was upgraded today in Ubuntu from your repository with your new update.  When Hybrid started under Ubuntu 14.04, there was no installation/download of aviSynth components like the last two releases.  I presume this is because it was already installed?

The bad news for me is that aviSynth still does not appear anywhere, even as a selection to be turned on all the time or disabled.  I am not using a DVD or BluRay input and am encoding to AVI.  I really need the suite of scripts that it offers, and I am completely flustered as to why it no longer appears in my setup. 

Can you offer any other advice or let me know what I should use as an attachment for you, there are no error logs since nothing is being encoded yet.

Thanks!

121 (edited by djcj 2015-10-21 16:37:10)

Re: Ubuntu repository - maintained by djcj

Delete the directory ~/.hybrid-bin/ and start it again. And make sure the package "hybrid-avisynth-extension" is installed. On the next start it should download the latest Hybrid and then the avisynth stuff.

If that still doesn't help, open a terminal and run "hybrid --log" or "hybrid-qt5 --log". And then post the log that was saved in ~/.hybrid/logs.

122

Re: Ubuntu repository - maintained by djcj

Hi djcj,

I did exactly as you instructed.  It then downloaded the latest hybrid and the aviSynth stuff, came up and still no aviSynth.

On a whim, I tried installing hybrid-avisynth-extension, but it said that I already had the latest version.  I did the log as you requested and it is attached herewith.

An interesting note is that although my system reports that hybrid-avisynth-extension is installed and already the latest version, the installer sayd it cannot find it.  Further, each time I start hybrid, it downloads and installs the latest version again!  Maybe you can puzzle something out from the log.

Would it be advisable to remove the whole program + extensions and start over?

Thanks,
Rhombic

123 (edited by djcj 2015-10-22 02:18:00)

Re: Ubuntu repository - maintained by djcj

rhombic wrote:

Hi djcj,
I did the log as you requested and it is attached herewith.

Where is it?

rhombic wrote:

Further, each time I start hybrid, it downloads and installs the latest version again!

Sounds like something in the script is not working as intended, but I have no idea what it might be.

rhombic wrote:

Would it be advisable to remove the whole program + extensions and start over?

You could give it a try, but remove ~/.hybrid-bin/ too. By the way, what happens if you start Hybrid directly from ~/.hybrid-bin/ by running '~/.hybrid-bin/Hybrid-521'?

edit:

Can you remove ~/.hybrid/misc.ini and try it again?

124 (edited by rhombic 2015-10-22 12:06:30)

Re: Ubuntu repository - maintained by djcj

Removing ~/hybrid/misc.ini fixed it!  Thanks!

Rhombic

125

Re: Ubuntu repository - maintained by djcj

Good to know what was causing the trouble. I've added a note to the first post.