51

Re: Frage zu I-Frames/ neu kodieren

Wenn ich aber am Anfang 5.1 habe, und diesen auf downmix 5.1 einstelle. Dann hab ich später keine Stelle, wo TSDoctor oder die MKVTools rummossern das auf einmal 2.0 drin ist und die Streams nicht zusammen passen.

52

Re: Frage zu I-Frames/ neu kodieren

Ich verstehe schon was Du machen willst, aber was Du brauchst ist ein Tool, welches den ac3 Stream entsprechend anpassen kann.
Hybrid wird eine Quelle mit 5.1 am Anfang  als 5.1 erkennen und den Decodern entsprechend auch sagen, dass der Inhalt 5.1 ist. Wenn der Inhalt jetzt reencoded wird (z.B. weil man einen Downmix machen will), wird der Encoder sobald er auf einen 2.0 Header stößt abstürzen.
-> Was man machen müsste um eine komplette Stereoquelle zu haben
1. den Audiostream extrahieren
2. den Audiostream komplett auf 5.1 patchen
(jetzt hätte man einen Stream der komplett als 5.1 erkannt wird)
3. den Decoden, Downmix nach Stereo machen und in das Zielformat umwandeln.
Problem: Das einzige Tool was mir bekannt ist, was Stereo Header auf 5.1 patchen kann ist Project X.
(durch die Abhängigkeit zu Java und der Tatsache, dass es schon ewig nicht mehr weiterentwickelt wird, werde ich dieses aber wohl nie in Hybrid integrieren)

Kann TsDoctor so etwas nicht?
(ging wohl mal: http://forum.cypheros.de/index.php?topic=1885.0)

Cu Selur

53

Re: Frage zu I-Frames/ neu kodieren

Also abstürzen tut Sox nicht, habs jetzt zwei oder dreimal getestet. Hab nun den Anfang weggeschnitten, so das 5.1 AC3 am Anfang steht, und dann nochma reencodet mit 5.1.

Das mit dem Fehler vom TSRemuxxer von TSDOC haste auch gelesen oder... auf einmal gehts, keine 50 fps mehr beim umwandeln....

54

Re: Frage zu I-Frames/ neu kodieren

Das mit dem Fehler vom TSRemuxxer von TSDOC haste auch gelesen oder... auf einmal gehts, keine 50 fps mehr beim umwandeln....

Ne, hatte nur wegen dem 5.1 patchen geguckt.

Also abstürzen tut Sox nicht, habs jetzt zwei oder dreimal getestet. Hab nun den Anfang weggeschnitten, so das 5.1 AC3 am Anfang steht, und dann nochma reencodet mit 5.1.

Auch gut. smile

55

Re: Frage zu I-Frames/ neu kodieren

Diese PES Längenangabe Fehler kommt aber auch im TSDoctor, wenn mich die m2ts aufmachen, die hybrid erstellt hat.
Hab nur grad keine Zeit und Lust zu testen , ob ich da auch diese ominöse Frameverdoppelung hab

56

Re: Frage zu I-Frames/ neu kodieren

Zum m2ts Multiplexen verwendet Hybrid tsMuxeR.
Schon komisch, da dies selber schreiben:

M2TS, AVCHD and Bluray export needs the free tsMuxeR!

Quelle: http://www.cypheros.de/tsdoctor_spec_e.html
-> Die sollten also Probleme mit dem Material haben, was sie selber erstellen.

57

Re: Frage zu I-Frames/ neu kodieren

Mhh jetzt hab ich noch ein anderes Problemchen, roll

laut hybrid ist das decoden/interlacen fehlerfrei durchgelaufen, aber das File hat teilweise nur die hälfte an Laufzeit und Größe.
Nach nen reset und erneuten durchlauf war es dann ok...

58

Re: Frage zu I-Frames/ neu kodieren

Sehr merkwürdig, dass Problem ist, dass ich das sicher hier nicht nachgestellt bekomme.
Hälfte der Laufzeit&Größe hört sich an als ob da irgendwas dazwischen funkt.
Was läuft denn bei Dir als mit Adminrechten was in die Kommunikation von anderen Tools eingreifen darf Firewall, Virenscanner?

59

Re: Frage zu I-Frames/ neu kodieren

Hab ich alles schon auf ein minimum herruntergefahrn, nur noch die Windows eigenen Boardmittel sind am laufen. Ansonsten halt das was noch von Graka,Sound usw geladen wird.

Die Jobs wurden im Hybrid alle als Finished bezeichnet, im moment codiere ich alle werbeblöcke einzeln. Dann hab ich nicht so grosses Verlust wenn wieder was hängt.

Von den letzten 5 Files wurde nur das erste bis Ende komplett bearbeitet, bei den anderen fehlte immer ein Stück.

60

Re: Frage zu I-Frames/ neu kodieren

Von den letzten 5 Files wurde nur das erste bis Ende komplett bearbeitet, bei den anderen fehlte immer ein Stück.

Wenn Du ein File hast was nicht komplett umgewandelt werden kann und dass nicht so riesig ist kannst Du es ja irgendwo hochladen und ich guck ob ich es hier umwandeln kann. Falls es hier auch nicht klappt kann ich nach dem Fehler suchen. smile

61 (edited by MarcusW 2014-10-07 13:55:36)

Re: Frage zu I-Frames/ neu kodieren

Das is es ja wieder, ich mach in den Jobs rechtsklick , -> reset und aufeinmal läuft es



Fubar, das mit avisynth nehm ich doch erstma zurück.... ist doch erst der durchgang mit deinterlacen... sorry

62

Re: Frage zu I-Frames/ neu kodieren

Das is es ja wieder, ich mach in den Jobs rechtsklick , -> reset und aufeinmal läuft es

Mal versucht ob es klappt, wenn Du Deine Kist nicht übertaktest?

63

Re: Frage zu I-Frames/ neu kodieren

Läuft alles auf Standard . Hab sogar BIOS alles auf Standard gesetzt. Hat auch nichts gebracht.

64

Re: Frage zu I-Frames/ neu kodieren

Dann ist es mir vollkommen unklar, was bei Dir passiert. smile
Wenn man nen Job resettet und ihn wieder startet wird das gleiche gemacht, sprich das einzige was sich ändern sollte ist was externes.

65

Re: Frage zu I-Frames/ neu kodieren

Hi,
kannst mal auf den Debugoutput schauen, hab heute nacht noch paar SD.mpeg durch den Hybrid gejagt.

Beim letzten hatte ich wieder das Problem , das er ständig "hängen blieb" , ich hab mal den debug von heute früh 7 uhr bis jetzt angehängt, hatte reset versucht, neustart versucht nichts, bleibt immer hängen.

Ich sehe da keine Meldung worauf ich schliessen kann  das er sich aufgehängt hat, da ist der aufruf , und dann kommt mein reset ....

Waren insgesamt 15 mpeg die ich im hybrid hatte...

66

Re: Frage zu I-Frames/ neu kodieren

Die x264.exe ausgetauscht? (gegen die von http://download.videolan.org/pub/x264/binaries/win64/)

67

Re: Frage zu I-Frames/ neu kodieren

nein, hatte ich nach dem letzten update nicht mehr. Hast du was auffälliges gesehn?

68

Re: Frage zu I-Frames/ neu kodieren

Ne, aber es scheint so, als ob der GCC irgendwelche SSE2 Optimierungen macht, die bei manchen Leute Probleme macht. (konnte das Problem bis dato hier nicht nachstellen)

69

Re: Frage zu I-Frames/ neu kodieren

GCC ??? achja , ist diesma stehn geblieben auch ohne das Avisynth gelaufen wäre....

70

Re: Frage zu I-Frames/ neu kodieren

GCC = Compiler der verwendet wird um x264 zu kompilieren. smile
Das Buildskript was ich verwendet hat letztens die GCC Version und die Optimierung geändert, was denke ich zu dem Problem führt.
-> ist nicht die Schuld von Hybrid an sich

71

Re: Frage zu I-Frames/ neu kodieren

Passt schon, sag nur bescheid wenns Dir zuviel wird, sich um meine Problemchen zukümmern.

Hab die x264 mal ersetzt, ma schaun was rauskommt wink

72

Re: Frage zu I-Frames/ neu kodieren

Kennst Du noch nen Trick zwei Video Dateien gleichzeitig öffnen und vorspulen.
Mit öffnen hab ich ja kein Problem , aber um dann irgendwo in die Mitte zu springen zum Vergleichen ist immer recht schwierig beide Fenster syncron zu bekommen, wenn Du weist was ich meine.

73

Re: Frage zu I-Frames/ neu kodieren

Wenn es nur um Bildvergleiche geht: beide Quellen in Avisynth öffnen (http://forum.gleitz.info/showthread.php … -abspielen)
oder
http://www.kinovea.org/
oder mit ffmpeg (http://ianfeather.co.uk/compare-two-web … ng-ffmpeg/)
...

74

Re: Frage zu I-Frames/ neu kodieren

Check mal bitte ob die angehängten Versionen bei Dir ohne einzufrieren laufen.

Cu Selur

75

Re: Frage zu I-Frames/ neu kodieren

Werd ich machen, kannst Du mal hier drüber schauen...

Hier hab ich das Problem, das es einfach unmotiviert das dekodieren aufhört, obwohl gar nicht fertig, aber wieder an ganz anderen stellen nach dem reset....

das andere x264 werd ich mal testen